summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/binding_of_caller')
-rw-r--r--dev-ruby/binding_of_caller/Manifest3
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild26
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r2.ebuild30
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild30
-rw-r--r--dev-ruby/binding_of_caller/metadata.xml2
5 files changed, 63 insertions, 28 deletions
diff --git a/dev-ruby/binding_of_caller/Manifest b/dev-ruby/binding_of_caller/Manifest
index 66a1b369f1bc..4f507d39cba8 100644
--- a/dev-ruby/binding_of_caller/Manifest
+++ b/dev-ruby/binding_of_caller/Manifest
@@ -1 +1,2 @@
-DIST binding_of_caller-0.8.0.gem 87552 BLAKE2B 9097fe2dbf1e5ea2361bee94cb83ce8152f7e1357caecf1217b1643be225e21e5aa793e7fccbef5c983d5c204b95e633ded490158dfdd1d4e99fca81c51cb910 SHA512 d6ea4e893415eaf3614b109f8f36c3fa2378da9997d013fccbd0fc1e598886d11f7843023ceed2468184d5b8df01e2329ef16c7af57bc60bbd47304a53b43974
+DIST binding_of_caller-1.0.0.tar.gz 7473 BLAKE2B 2a8f3cee555e11c9eeb56935d0ee51deb037ea5fc631b4ef5eb50a831e48ba47c6a94e9104456bd8e6c4910bc76c5bc7e268db7de8c5ed283886b80c3feffd62 SHA512 89c58fec180b7bc25c5124035ed69692961148a3ddcb561643e7b8b1a78c3b103795408b52e70264db7c4b62080991219af977c5b981a135d573ecd56cebebba
+DIST binding_of_caller-1.0.1.tar.gz 7514 BLAKE2B 1a6786d4fa2a01f72bf5b38f8fced3950826488501fa15fb8b37188e345d6a93ce8a4598f7c4c0048ca05bfae8ff23daab8a0fb89da3140f83f20dbca60ae1f3 SHA512 ebdcb2e0e41efef38eec2aa814f4d875249e1fb4f4719238fae2c92533a37324fe64bc9edbebddf2d240f0c3dd213fddf1584cb9841e4fc946c6aecbe8543e34
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
deleted file mode 100644
index a634b5730bdb..000000000000
--- a/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="HISTORY README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Retrieve the binding of a method's caller"
-HOMEPAGE="https://github.com/banister/binding_of_caller"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
-
-ruby_add_bdepend "test? ( dev-ruby/bacon )"
-
-each_ruby_test() {
- ${RUBY} -S bacon -Itest -rubygems -a -q || die
-}
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r2.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..4f1a7d57733e
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="binding_of_caller.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+SRC_URI="https://github.com/banister/binding_of_caller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+all_ruby_prepare() {
+ sed -i -e "s:_relative ': './:" -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild
new file mode 100644
index 000000000000..90fe35a91cb9
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="binding_of_caller.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+SRC_URI="https://github.com/banister/binding_of_caller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-1.2.0"
+
+all_ruby_prepare() {
+ sed -i -e "s:_relative ': './:" -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/binding_of_caller/metadata.xml b/dev-ruby/binding_of_caller/metadata.xml
index b7fe626b3cd7..28a805750a43 100644
--- a/dev-ruby/binding_of_caller/metadata.xml
+++ b/dev-ruby/binding_of_caller/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>ruby@gentoo.org</email>