summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bunny/bunny-1.7.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-1.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-1.7.0.ebuild b/dev-ruby/bunny/bunny-1.7.0.ebuild
new file mode 100644
index 000000000000..da0ff7ed81c2
--- /dev/null
+++ b/dev-ruby/bunny/bunny-1.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="http://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-1.9.2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+}