summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild')
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..2eb3a29098f3
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="http://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_http_parser extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ruby_http_parser V=1
+ cp ext/ruby_http_parser/ruby_http_parser.so lib/ || die
+}