summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/itextomml/itextomml-1.6.0.ebuild')
-rw-r--r--dev-ruby/itextomml/itextomml-1.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/itextomml/itextomml-1.6.0.ebuild b/dev-ruby/itextomml/itextomml-1.6.0.ebuild
new file mode 100644
index 000000000000..22fcbeb33d94
--- /dev/null
+++ b/dev-ruby/itextomml/itextomml-1.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Native Ruby bindings to itex2MML, which converts itex equations to MathML"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+#Tests don't fail here
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/itex2MML$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/test_itextomml.rb || die
+}