summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/litc/litc-1.0.3-r1.ebuild')
-rw-r--r--dev-ruby/litc/litc-1.0.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/litc/litc-1.0.3-r1.ebuild b/dev-ruby/litc/litc-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..cbaec9e03bfb
--- /dev/null
+++ b/dev-ruby/litc/litc-1.0.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="rerdoc"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A tiny ruby module for Amazon EC2 intance metadata"
+HOMEPAGE="http://github.com/bkaney/litc"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda dev-ruby/fakeweb dev-ruby/minitest:0 )"
+
+all_ruby_prepare() {
+ # Don't check dependencies since we provide slightly different packages.
+ sed -i -e '/check_dependencies/d'\
+ -e 's#rake/rdoctask#rdoc/task#' Rakefile || die
+ sed -i -e '/ruby-debug/ s:^:#:' \
+ -e '2agem "minitest", "~> 4.0"' test/helper.rb || die
+}