summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/Manifest3
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.2.3.ebuild33
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.2.4.ebuild33
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.2.7.ebuild33
4 files changed, 0 insertions, 102 deletions
diff --git a/dev-ruby/pkg-config/Manifest b/dev-ruby/pkg-config/Manifest
index b57f75b2cfbe..ad7d74a335f5 100644
--- a/dev-ruby/pkg-config/Manifest
+++ b/dev-ruby/pkg-config/Manifest
@@ -1,5 +1,2 @@
DIST pkg-config-1.1.7.gem 19456 BLAKE2B ae6f3641181a60aa46a2da63a5343f23c4a41a9499ff5e00b1115ddfb328a4db33db2890d234f5cbc9a45af28aa537e886c776f0a8f24e54e307f637e5a2c8ae SHA512 9f515874d3edabdfff5f4c8d624bbc91e9c5032e79c241412cd073f0a049e35a2e2a660d5503eaae9640286d74cb98510bbbb34f757c702e220f728fba1c2337
-DIST pkg-config-1.2.3.gem 19968 BLAKE2B 2db6c37aecbcbe63aee639a8cba99840d618a24877ada52838bda4c5775bfe8ca2d555cacad9bf53477882df555cf118c43bf54c9360d5cf05b21e7b4b136629 SHA512 1e0ec12cdb9647d9d5b29c48940f15dcf27e346a18b9f33922a5b8e0a57957206981cf5c7dd70da36fdb2a32bbe8e3ac38737f66abc5f5afa8b4dabf52a696fd
-DIST pkg-config-1.2.4.gem 19968 BLAKE2B a33bfe33e6f15c528e310363362182ac68c0c7f5745f7044973309d478864187caf66aeed9398304465c650b6739845711f83736202b8e073c80fa4e8b59d24a SHA512 74abccc5b067d4b98bc1aa20eaf990f1e31f8ab9251f8081440dd2b11e9d14ffe82ccff92d0858386e11fe3ff4f8927da7ca17d382946e4b0c3dbd7a45ffae24
-DIST pkg-config-1.2.7.gem 20480 BLAKE2B 2445c96c9defb547ef21d62912c7c882bee8b80561ec221c3605e907189b94243d4ad78ae180ea5414350b5b299f8f7f2468e0d910673f2e7c9c48d98e7cc844 SHA512 88a0d0c616e4c00dcdc25980c532476eb9c9ff17e9f8a015c414cf2f536c558bc10656e2a56dbe01f34c016e86fc92959f2231a07e03b541c32c79ab36423760
DIST pkg-config-1.2.8.gem 20480 BLAKE2B cc11b5eff30f0f5e1a91e64902931ed540da108fd326fe731b71527c9c4310f55e9002617e1baae4f71a4b705b20cf10f6fa112f8ef56971e82868145d372a47 SHA512 d83a599a48c7d404946054c6846b6cfd9fce2a264c288519a6eccd9787f05d45397dd46300bf97c80700921456318154ea6d44ba32cd159803471073c2a2b065
diff --git a/dev-ruby/pkg-config/pkg-config-1.2.3.ebuild b/dev-ruby/pkg-config/pkg-config-1.2.3.ebuild
deleted file mode 100644
index 4cefe1fadf72..000000000000
--- a/dev-ruby/pkg-config/pkg-config-1.2.3.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A pkg-config implementation by Ruby"
-HOMEPAGE="https://github.com/rcairo/pkg-config"
-LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
-# this is used for testing
-DEPEND+=" test? ( x11-libs/cairo )"
-
-all_ruby_prepare() {
- # drop failing tests
- sed -i -e "/test_cflags/,/end/d"\
- -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
-}
diff --git a/dev-ruby/pkg-config/pkg-config-1.2.4.ebuild b/dev-ruby/pkg-config/pkg-config-1.2.4.ebuild
deleted file mode 100644
index 4cefe1fadf72..000000000000
--- a/dev-ruby/pkg-config/pkg-config-1.2.4.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A pkg-config implementation by Ruby"
-HOMEPAGE="https://github.com/rcairo/pkg-config"
-LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
-# this is used for testing
-DEPEND+=" test? ( x11-libs/cairo )"
-
-all_ruby_prepare() {
- # drop failing tests
- sed -i -e "/test_cflags/,/end/d"\
- -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
-}
diff --git a/dev-ruby/pkg-config/pkg-config-1.2.7.ebuild b/dev-ruby/pkg-config/pkg-config-1.2.7.ebuild
deleted file mode 100644
index 4cefe1fadf72..000000000000
--- a/dev-ruby/pkg-config/pkg-config-1.2.7.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A pkg-config implementation by Ruby"
-HOMEPAGE="https://github.com/rcairo/pkg-config"
-LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-SLOT="0"
-IUSE="test"
-
-ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
-# this is used for testing
-DEPEND+=" test? ( x11-libs/cairo )"
-
-all_ruby_prepare() {
- # drop failing tests
- sed -i -e "/test_cflags/,/end/d"\
- -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
-}
-
-each_ruby_test() {
- ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb || die
-}