summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rack-protection/rack-protection-1.5.3.ebuild')
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.5.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/rack-protection-1.5.3.ebuild b/dev-ruby/rack-protection/rack-protection-1.5.3.ebuild
new file mode 100644
index 000000000000..75bf6f68b1ec
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.5.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test )"