summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/metadata.xml12
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.5.3-r1.ebuild24
-rw-r--r--dev-ruby/rack-protection/rack-protection-1.5.3.ebuild24
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
new file mode 100644
index 000000000000..fad547b4b459
--- /dev/null
+++ b/dev-ruby/rack-protection/Manifest
@@ -0,0 +1 @@
+DIST rack-protection-1.5.3.gem 18432 SHA256 b9c08cb17b13c6672ef642cc4855b4c4ba8fcb1f66abc687f03cddf37f106b33 SHA512 9f94f9f25197c3f8227f5c9c9fd2e896e35bfc08d4a20f4dded9c42772f348d16dceda6916429833b498b29c4dbba4dbb31b1a3cf90de597fb6df2de145d655a WHIRLPOOL f1c3b7ddc9dedfefb6d7509bccfd43cf594c7d1234a41fe39ce8740c97d2b1a09c0dd2c8112d1751c93c32380442696c8d5cd7e7e6e1bbaa9ae441601f596883
diff --git a/dev-ruby/rack-protection/metadata.xml b/dev-ruby/rack-protection/metadata.xml
new file mode 100644
index 000000000000..a5d28ce40210
--- /dev/null
+++ b/dev-ruby/rack-protection/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <longdescription>
+Rack provides a common API for connecting web frameworks, web servers and layers
+of software inbetween.
+</longdescription>
+ <upstream>
+ <remote-id type="github">rkh/rack-protection</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rack-protection/rack-protection-1.5.3-r1.ebuild b/dev-ruby/rack-protection/rack-protection-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..a26909c57b3b
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.5.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test )"
diff --git a/dev-ruby/rack-protection/rack-protection-1.5.3.ebuild b/dev-ruby/rack-protection/rack-protection-1.5.3.ebuild
new file mode 100644
index 000000000000..75bf6f68b1ec
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-1.5.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rack-protection.gemspec"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rack-test )"