summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0.ebuild')
-rw-r--r--dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0.ebuild b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0.ebuild
new file mode 100644
index 000000000000..2a62a3eca747
--- /dev/null
+++ b/dev-ruby/rex-random_identifier/rex-random_identifier-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for generating Random identifier strings"
+HOMEPAGE="https://rubygems.org/gems/rex-random_identifier"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# doesn't seem to actually run any tests
+RESTRICT=test
+
+ruby_add_bdepend "dev-ruby/rex-text"
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper console ${PN}-console
+ ruby_fakegem_binwrapper setup ${PN}-setup
+}