summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild')
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild
new file mode 100644
index 000000000000..3543a798501a
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses."
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+all_ruby_prepare() {
+ sed -i -e '1irequire "forwardable"' lib/rspec/json_expectations/matchers.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}