summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-inifile/ruby-inifile-2.0.0-r2.ebuild')
-rw-r--r--dev-ruby/ruby-inifile/ruby-inifile-2.0.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/ruby-inifile/ruby-inifile-2.0.0-r2.ebuild b/dev-ruby/ruby-inifile/ruby-inifile-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..196d30e39ccf
--- /dev/null
+++ b/dev-ruby/ruby-inifile/ruby-inifile-2.0.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# ruby22 -> Incompatible code
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-ng
+
+DESCRIPTION="Small library to parse INI-files in Ruby"
+HOMEPAGE="http://raa.ruby-lang.org/project/ruby-inifile/"
+SRC_URI="http://gregoire.lejeune.free.fr/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+IUSE=""
+LICENSE="Ruby"
+KEYWORDS="~amd64 ~x86"
+RUBY_S=${PN}
+
+each_ruby_test() {
+ cd tests
+ for test in *.rb ; do
+ ${RUBY} -I../lib $test || die
+ done
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb config --prefix="${D}"/usr || die
+ ${RUBY} setup.rb install || die
+}
+
+all_ruby_install() {
+ dodoc AUTHORS README
+}