summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild')
-rw-r--r--dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild
new file mode 100644
index 000000000000..eb2623a01f63
--- /dev/null
+++ b/dev-ruby/ruby-mp3info/ruby-mp3info-0.8.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby library for access to mp3 files (internal infos and tags)"
+HOMEPAGE="http://rubyforge.org/projects/ruby-mp3info/"
+SRC_URI="https://github.com/moumar/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+DEPEND+=" test? ( media-sound/id3v2 )"
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Use a newer test-unit than is shipped with ruby19
+ sed -i -e '6igem "test-unit"' test/test_ruby-mp3info.rb || die
+}