summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-ole/ruby-ole-1.2.12.2.ebuild')
-rw-r--r--dev-ruby/ruby-ole/ruby-ole-1.2.12.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ole/ruby-ole-1.2.12.2.ebuild b/dev-ruby/ruby-ole/ruby-ole-1.2.12.2.ebuild
new file mode 100644
index 000000000000..ef0d993916a9
--- /dev/null
+++ b/dev-ruby/ruby-ole/ruby-ole-1.2.12.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+# Avoid the complexity of the "rake" recipe and run testrb-2 manually.
+RUBY_FAKEGEM_RECIPE_TEST=none
+
+# Same thing for the docs whose rake target just calls rdoc.
+RUBY_FAKEGEM_RECIPE_DOC=rdoc
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for easy read/write access to OLE compound documents"
+HOMEPAGE="https://github.com/aquasync/ruby-ole"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 --pattern='test.*\.rb' test/
+}