summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild')
-rw-r--r--dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild b/dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild
deleted file mode 100644
index a42584281897..000000000000
--- a/dev-ruby/rubypants/rubypants-0.2.0-r4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-USE_RUBY="ruby20"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby port of the SmartyPants PHP library"
-HOMEPAGE="http://chneukirchen.org/repos/rubypants/README"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-all_ruby_prepare() {
- # the metadata format is ancient, and has quite a bit of trouble,
- # remove it and let it use a generated one.
- rm -f ../metadata || die
-}
-
-each_ruby_install() {
- ruby_fakegem_install_gemspec
-
- ruby_fakegem_newins rubypants.rb lib/rubypants.rb
-}
-
-each_ruby_test() {
- # The rakefile doesn't really implement it properly, so simply
- # replace it here.
- ${RUBY} -I. test_rubypants.rb || die "tests failed"
-}