summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild')
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild
new file mode 100644
index 000000000000..0b6ba5c30db1
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ <dev-ruby/mocha-1 )"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
+}
+each_ruby_test() {
+ ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}