summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/subexec')
-rw-r--r--dev-ruby/subexec/subexec-0.2.3-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/subexec/subexec-0.2.3-r2.ebuild b/dev-ruby/subexec/subexec-0.2.3-r2.ebuild
new file mode 100644
index 000000000000..f689733762be
--- /dev/null
+++ b/dev-ruby/subexec/subexec-0.2.3-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="subexec.gemspec"
+
+inherit ruby-fakegem
+
+GITHUB_USER="nulayer"
+
+DESCRIPTION="Subexec spawns an external command with a timeout"
+HOMEPAGE="https://github.com/nulayer/subexec"
+SRC_URI="https://github.com/${GITHUB_USER}/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/shoulda )"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+ sed -i -e '/begin/,/end/ s:^:#:' spec/spec_helper.rb || die
+}