summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild')
-rw-r--r--dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild b/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild
new file mode 100644
index 000000000000..aef1590a029d
--- /dev/null
+++ b/dev-ruby/transaction-simple/transaction-simple-1.4.0.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides transaction support at the object level"
+HOMEPAGE="https://github.com/halostatue/transaction-simple"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_*.rb
+}