summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/travis')
-rw-r--r--dev-ruby/travis/Manifest1
-rw-r--r--dev-ruby/travis/travis-1.8.8.ebuild57
-rw-r--r--dev-ruby/travis/travis-1.8.9.ebuild57
3 files changed, 0 insertions, 115 deletions
diff --git a/dev-ruby/travis/Manifest b/dev-ruby/travis/Manifest
index a3e6d10d054a..91fa2e01718f 100644
--- a/dev-ruby/travis/Manifest
+++ b/dev-ruby/travis/Manifest
@@ -1,2 +1 @@
-DIST travis-1.8.8.gem 192512 BLAKE2B 6671b4c8b2e3ea0b374f523e8089fd8f0bb60b0d03e0ba387138c7df926565dfe4bfa7e04926d3dfe0514a9ad6d660ba4c182c947dd605ef30f73275730cddbc SHA512 f4fca2278de7263a0f4889c64dd6f78927355eece73cc600e704d0bebba2efaf86f78b8d608c0859d83c33f04b7fde47f33a4b6307d7799ff312705b40c7d563
DIST travis-1.8.9.gem 193536 BLAKE2B b889127e07b2126ef193d64361059d514db4df4e3dc70fd30b55dac3fe67624df20d156aa6d9842d6bb766788626358ab38d7e6a59455c91a80925628e30764b SHA512 fce5dfb8071629de172b8a91fad15b1d6fcc50af1ab1a41eaa1e5eb91042b90fd58e1be24779fb02972077af743ebd65183b2dff42ee47d48818f7ed2755980a
diff --git a/dev-ruby/travis/travis-1.8.8.ebuild b/dev-ruby/travis/travis-1.8.8.ebuild
deleted file mode 100644
index 4e300eecdaf4..000000000000
--- a/dev-ruby/travis/travis-1.8.8.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_EXTRAINSTALL="assets"
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="Travis CI Client (CLI and Ruby library)"
-HOMEPAGE="https://github.com/travis-ci/travis.rb"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-#RESTRICT="test"
-
-DEPEND+="test? ( dev-vcs/git )"
-RDEPEND+="dev-vcs/git"
-
-ruby_add_bdepend "
- test? ( >dev-ruby/rack-test-0.6 )
- >dev-ruby/sinatra-1.3
-"
-
-ruby_add_rdepend "
- dev-ruby/backports
- >dev-ruby/faraday-0.9
- >=dev-ruby/faraday_middleware-0.9.1
- >dev-ruby/gh-0.13
- >dev-ruby/highline-1.6
- >dev-ruby/launchy-2.1
- >dev-ruby/pusher-client-0.4
- dev-ruby/typhoeus:0
-"
-
-all_ruby_prepare() {
- if use test ; then
- git init --quiet . || die
- git remote add origin "${HOMEPAGE}" || die
- touch .travis.yml || die
- fi
-
- # Remove failing spec where cause is not fully clear.
- # May be related to highline compatibility issues.
- rm spec/cli/login_spec.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp "assets/travis.sh" "travis"
-}
diff --git a/dev-ruby/travis/travis-1.8.9.ebuild b/dev-ruby/travis/travis-1.8.9.ebuild
deleted file mode 100644
index 9e8cc0ce88e3..000000000000
--- a/dev-ruby/travis/travis-1.8.9.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_EXTRAINSTALL="assets"
-
-inherit bash-completion-r1 ruby-fakegem
-
-DESCRIPTION="Travis CI Client (CLI and Ruby library)"
-HOMEPAGE="https://github.com/travis-ci/travis.rb"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-#RESTRICT="test"
-
-DEPEND+="test? ( dev-vcs/git )"
-RDEPEND+="dev-vcs/git"
-
-ruby_add_bdepend "
- test? ( >dev-ruby/rack-test-0.6 )
- >dev-ruby/sinatra-1.3
-"
-
-ruby_add_rdepend "
- dev-ruby/backports
- >dev-ruby/faraday-0.9
- >=dev-ruby/faraday_middleware-0.9.1
- >dev-ruby/gh-0.13
- >=dev-ruby/highline-1.6:0
- >dev-ruby/launchy-2.1
- >dev-ruby/pusher-client-0.4
- dev-ruby/typhoeus:0
-"
-
-all_ruby_prepare() {
- if use test ; then
- git init --quiet . || die
- git remote add origin "${HOMEPAGE}" || die
- touch .travis.yml || die
- fi
-
- # Remove failing spec where cause is not fully clear.
- # May be related to highline compatibility issues.
- rm spec/cli/login_spec.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newbashcomp "assets/travis.sh" "travis"
-}