summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tls/tls-1.6.7.ebuild')
-rw-r--r--dev-tcltk/tls/tls-1.6.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tcltk/tls/tls-1.6.7.ebuild b/dev-tcltk/tls/tls-1.6.7.ebuild
new file mode 100644
index 000000000000..065cbe9b6ba8
--- /dev/null
+++ b/dev-tcltk/tls/tls-1.6.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="TLS OpenSSL extension to Tcl"
+HOMEPAGE="http://tls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tls/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="tk"
+
+DEPEND="
+ dev-lang/tcl:0=
+ dev-libs/openssl:0=
+ tk? ( dev-lang/tk:0= )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf \
+ --with-ssl-dir="${EPREFIX}/usr" \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_install() {
+ default
+ dohtml tls.htm
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # this is ugly, but fixing the makefile mess is even worse
+ local loc=usr/$(get_libdir)/tls1.6/libtls1.6.dylib
+ install_name_tool -id "${EPREFIX}"/${loc} "${ED}"/${loc} || die
+ fi
+}