summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latexdiff/latexdiff-1.1.1.ebuild')
-rw-r--r--dev-tex/latexdiff/latexdiff-1.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-tex/latexdiff/latexdiff-1.1.1.ebuild b/dev-tex/latexdiff/latexdiff-1.1.1.ebuild
new file mode 100644
index 000000000000..12b68233b2e2
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+SRC_URI="http://mirror.ctan.org/support/${PN}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_test() {
+ emake test-ext
+}
+
+src_install() {
+ dobin latexdiff latexrevise latexdiff-vc
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1
+ dodoc README doc/latexdiff-man.pdf
+}