summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latexdiff')
-rw-r--r--dev-tex/latexdiff/Manifest3
-rw-r--r--dev-tex/latexdiff/latexdiff-0.5.ebuild30
-rw-r--r--dev-tex/latexdiff/latexdiff-1.0.4.ebuild32
-rw-r--r--dev-tex/latexdiff/latexdiff-1.1.0.ebuild32
-rw-r--r--dev-tex/latexdiff/metadata.xml8
5 files changed, 105 insertions, 0 deletions
diff --git a/dev-tex/latexdiff/Manifest b/dev-tex/latexdiff/Manifest
new file mode 100644
index 000000000000..3a6d9e08eedb
--- /dev/null
+++ b/dev-tex/latexdiff/Manifest
@@ -0,0 +1,3 @@
+DIST latexdiff-0.5.zip 310412 SHA256 7a99ac274c7552b1acf617d27866b40573469acafde0fb680231e58b2e08ddcf SHA512 fc0ff701f7c79842c0325923389a5118b626cfbea12ede0f98fc5e8311ac63fbc371fb5b1f4b4b50247112e16b0ac2fed8f5513d1c85dc1a69c97eb7f3a78351 WHIRLPOOL 06d0062c01b98f695bda8ee113faf247dae526451701aa91060a8cfacd7a7a13bd2d45235b641260fd2f2ebe9120364fe855c3d7959be45b10fcd7f03092987c
+DIST latexdiff-1.0.4.zip 445374 SHA256 42acfc6e379f61637d2d23f5dd940373cd1f0ef54858eaecb3f6dad250af2db1 SHA512 5ab3e00d94053f4d73e2a0ae47e7e98c2b53d1acd9411c2f2a5f438bc69cd13b1d3be19fe466d63f6fdcec3b132144ffe8409cdc8ff41a9fb0e408767f94ec61 WHIRLPOOL cda44d78a9ca53cb7b9668d31c31da61735f496120ba855fe8c83895907e396b30152ebf2076ec436a9a8454510c2db2229e75d913bba6ed9532e816d7d1221b
+DIST latexdiff-1.1.0.zip 466029 SHA256 9f0cc207d71a2225926cf9b8b87dbc4283c68de12db8a7708e780941516f13f6 SHA512 04af20386b0e611f73d981242747316da6376967fef611a29927b66a7a129bec49c7224655378c6f9fc744f8d69cf2ac977d0f50278d3686c98dcdc4aef0b675 WHIRLPOOL 944fe49aac3aaf8801a1e8c345551cf73ce5d205cd32c0ab5e6f1d1acafcaefb60f0d8a47488e6a7513139de89b7b78b7acc155cac4c328918dc33e79f12a7ed
diff --git a/dev-tex/latexdiff/latexdiff-0.5.ebuild b/dev-tex/latexdiff/latexdiff-0.5.ebuild
new file mode 100644
index 000000000000..eb9f52ffe49e
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-0.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_test() {
+ emake test-ext || die "Tests failed!"
+}
+
+src_install() {
+ dobin latexdiff latexrevise latexdiff-vc || die "dobin failed"
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1 || die "doman failed"
+ dodoc CHANGES README latexdiff-man.pdf || die "dodoc failed"
+}
diff --git a/dev-tex/latexdiff/latexdiff-1.0.4.ebuild b/dev-tex/latexdiff/latexdiff-1.0.4.ebuild
new file mode 100644
index 000000000000..12b68233b2e2
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-1.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+SRC_URI="http://mirror.ctan.org/support/${PN}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_test() {
+ emake test-ext
+}
+
+src_install() {
+ dobin latexdiff latexrevise latexdiff-vc
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1
+ dodoc README doc/latexdiff-man.pdf
+}
diff --git a/dev-tex/latexdiff/latexdiff-1.1.0.ebuild b/dev-tex/latexdiff/latexdiff-1.1.0.ebuild
new file mode 100644
index 000000000000..12b68233b2e2
--- /dev/null
+++ b/dev-tex/latexdiff/latexdiff-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Compare two latex files and mark up significant differences"
+HOMEPAGE="http://www.ctan.org/tex-archive/support/latexdiff/ https://github.com/ftilmann/latexdiff/"
+SRC_URI="http://mirror.ctan.org/support/${PN}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8
+ dev-perl/Algorithm-Diff"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_test() {
+ emake test-ext
+}
+
+src_install() {
+ dobin latexdiff latexrevise latexdiff-vc
+ doman latexdiff.1 latexrevise.1 latexdiff-vc.1
+ dodoc README doc/latexdiff-man.pdf
+}
diff --git a/dev-tex/latexdiff/metadata.xml b/dev-tex/latexdiff/metadata.xml
new file mode 100644
index 000000000000..d7b73cd8be89
--- /dev/null
+++ b/dev-tex/latexdiff/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <upstream>
+ <remote-id type="github">ftilmann/latexdiff</remote-id>
+ </upstream>
+</pkgmetadata>