summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latexmk/latexmk-435.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-435.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-435.ebuild b/dev-tex/latexmk/latexmk-435.ebuild
new file mode 100644
index 000000000000..b26297e198c4
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-435.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}