summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/latexmk/latexmk-445.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-445.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-445.ebuild b/dev-tex/latexmk/latexmk-445.ebuild
new file mode 100644
index 000000000000..a46fbb239307
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-445.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.ps latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}