summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild b/dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild
new file mode 100644
index 000000000000..0de71abc833b
--- /dev/null
+++ b/dev-tex/dvi2gr/dvi2gr-0.4-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="DVI to Grace translator"
+HOMEPAGE="http://plasma-gate.weizmann.ac.il/Grace/"
+SRC_URI="ftp://plasma-gate.weizmann.ac.il/pub/grace/src/devel/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="media-libs/t1lib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ tc-export CC
+ default
+ # respect flags
+ sed -i \
+ -e '/^LDFLAGS/d' -e '/^CFLAGS/d' -e '/^CC/d' \
+ Makefile || die
+ sed -i -e 's/DVI2GR=\.\/dvi2gr/DVI2GR=$(which dvi2gr)/g' runtest.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins *.ti runtest.sh
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r fonts
+}
+
+pkg_postinst() {
+ einfo "Don't forget install the TeX-Fonts in Grace"
+ einfo " /usr/share/${PN}/fonts/FontDataBase"
+}