summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-texlive/texlive-xetex/texlive-xetex-2013.ebuild')
-rw-r--r--dev-texlive/texlive-xetex/texlive-xetex-2013.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-texlive/texlive-xetex/texlive-xetex-2013.ebuild b/dev-texlive/texlive-xetex/texlive-xetex-2013.ebuild
new file mode 100644
index 000000000000..f111bc9d3e03
--- /dev/null
+++ b/dev-texlive/texlive-xetex/texlive-xetex-2013.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+TEXLIVE_MODULE_CONTENTS="arabxetex euenc fixlatvian fontbook fontwrap mathspec philokalia polyglossia ptext realscripts ucharclasses unisugar xecjk xecolor xecyr xeindex xepersian xesearch xetex xetex-def xetex-itrans xetex-pstricks xetex-tibetan xetexconfig xetexfontinfo xetexko xevlna xltxtra xunicode collection-xetex
+"
+TEXLIVE_MODULE_DOC_CONTENTS="arabxetex.doc euenc.doc fixlatvian.doc fontbook.doc fontwrap.doc mathspec.doc philokalia.doc polyglossia.doc ptext.doc realscripts.doc ucharclasses.doc unisugar.doc xecjk.doc xecolor.doc xecyr.doc xeindex.doc xepersian.doc xesearch.doc xetex.doc xetex-itrans.doc xetex-pstricks.doc xetex-tibetan.doc xetexfontinfo.doc xetexko.doc xevlna.doc xltxtra.doc xunicode.doc "
+TEXLIVE_MODULE_SRC_CONTENTS="arabxetex.source euenc.source fixlatvian.source fontbook.source philokalia.source polyglossia.source realscripts.source xecjk.source xepersian.source xltxtra.source "
+inherit font texlive-module
+DESCRIPTION="TeXLive XeTeX and packages"
+
+LICENSE=" Apache-2.0 GPL-1 GPL-2 LPPL-1.2 LPPL-1.3 OFL public-domain TeX-other-free "
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+DEPEND=">=dev-texlive/texlive-basic-2013
+!=app-text/texlive-core-2007*
+>=dev-texlive/texlive-latexextra-2010
+>=app-text/texlive-core-2010[xetex]
+>=dev-texlive/texlive-genericrecommended-2010
+>=dev-texlive/texlive-mathextra-2012
+!<dev-texlive/texlive-mathextra-2012
+"
+RDEPEND="${DEPEND} "
+FONT_CONF=( "${FILESDIR}"/09-texlive.conf )
+
+src_install() {
+ texlive-module_src_install
+ font_fontconfig
+}
+
+pkg_postinst() {
+ texlive-module_pkg_postinst
+ font_pkg_postinst
+}
+
+pkg_postrm() {
+ texlive-module_pkg_postrm
+ font_pkg_postrm
+}