summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/build/build-0.3.9.ebuild')
-rw-r--r--dev-util/build/build-0.3.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/build/build-0.3.9.ebuild b/dev-util/build/build-0.3.9.ebuild
new file mode 100644
index 000000000000..9261a4a280c7
--- /dev/null
+++ b/dev-util/build/build-0.3.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit versionator
+
+DESCRIPTION="A massively-parallel software build system implemented on top of GNU make"
+HOMEPAGE="http://kolpackov.net/projects/build/"
+SLOT="$(get_version_component_range 1-2)"
+SRC_URI="http://www.codesynthesis.com/download/${PN}/${SLOT}/${P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ emake install_prefix="${D}/usr" install
+
+ dodoc documentation/[[:upper:]]*
+ dohtml -A xhtml documentation/*.{css,xhtml}
+
+ if use examples ; then
+ # preserving symlinks in the examples
+ cp -dpR examples "${D}/usr/share/doc/${PF}"
+ fi
+}