summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cpputest/cpputest-3.7.2.ebuild')
-rw-r--r--dev-util/cpputest/cpputest-3.7.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/cpputest/cpputest-3.7.2.ebuild b/dev-util/cpputest/cpputest-3.7.2.ebuild
new file mode 100644
index 000000000000..f5f12570b54a
--- /dev/null
+++ b/dev-util/cpputest/cpputest-3.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="unit testing and mocking framework for C/C++"
+HOMEPAGE="http://cpputest.github.io/ https://github.com/cpputest/cpputest"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-cpp/gmock
+ dev-cpp/gtest
+ )
+"
+
+DOCS=( AUTHORS README.md README_CppUTest_for_C.txt )