summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/google-perftools-2.9.1-r2.ebuild (renamed from dev-util/google-perftools/google-perftools-2.9.1-r1.ebuild)13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-util/google-perftools/google-perftools-2.9.1-r1.ebuild b/dev-util/google-perftools/google-perftools-2.9.1-r2.ebuild
index ed4a219b335d..0ac7aaf851de 100644
--- a/dev-util/google-perftools/google-perftools-2.9.1-r1.ebuild
+++ b/dev-util/google-perftools/google-perftools-2.9.1-r2.ebuild
@@ -4,7 +4,7 @@
EAPI=7
MY_P="gperftools-${PV}"
-inherit toolchain-funcs flag-o-matic autotools vcs-snapshot multilib-minimal
+inherit flag-o-matic autotools vcs-snapshot multilib-minimal
DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
HOMEPAGE="https://github.com/gperftools/gperftools"
@@ -64,13 +64,18 @@ multilib_src_configure() {
use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
append-flags -fno-strict-aliasing -fno-omit-frame-pointer
- local myconfargs=(
+ local myeconfargs=(
--enable-shared
$(use_enable static-libs static)
$(use_enable debug debugalloc)
- $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
)
+ if [[ ${ABI} == x32 ]]; then
+ myeconfargs+=( --enable-minimal )
+ else
+ myeconfargs+=( $(use_enable minimal) )
+ fi
+
if use arm64 || use s390; then
# Use the same arches for disabling TLS (thread local storage)
# as Fedora, but we might need to expand this list if we get
@@ -78,7 +83,7 @@ multilib_src_configure() {
myeconfargs+=( --disable-general-dynamic-tls )
fi
- econf "${myconfargs[@]}"
+ econf "${myeconfargs[@]}"
}
src_test() {