summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lttng-ust/lttng-ust-2.10.1.ebuild')
-rw-r--r--dev-util/lttng-ust/lttng-ust-2.10.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/lttng-ust/lttng-ust-2.10.1.ebuild b/dev-util/lttng-ust/lttng-ust-2.10.1.ebuild
new file mode 100644
index 000000000000..1a0e55bb0ad0
--- /dev/null
+++ b/dev-util/lttng-ust/lttng-ust-2.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - UST library"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-libs/userspace-rcu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ default
+ if ! use examples; then
+ sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF}
+}