summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/re2c/re2c-0.13.7.5.ebuild')
-rw-r--r--dev-util/re2c/re2c-0.13.7.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-0.13.7.5.ebuild b/dev-util/re2c/re2c-0.13.7.5.ebuild
new file mode 100644
index 000000000000..8e06d4f9ab06
--- /dev/null
+++ b/dev-util/re2c/re2c-0.13.7.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ touch re2c.1 # don't require asciidoc for mans
+ emake
+}
+
+src_install() {
+ default
+
+ dodoc README CHANGELOG doc/*
+ docinto examples
+ dodoc examples/*.c examples/*.re
+}