summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/roctracer/roctracer-5.1.3-r1.ebuild')
-rw-r--r--dev-util/roctracer/roctracer-5.1.3-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/roctracer/roctracer-5.1.3-r1.ebuild b/dev-util/roctracer/roctracer-5.1.3-r1.ebuild
index 1154d03f8c16..22befb0d4430 100644
--- a/dev-util/roctracer/roctracer-5.1.3-r1.ebuild
+++ b/dev-util/roctracer/roctracer-5.1.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake prefix python-any-r1
@@ -38,8 +38,8 @@ PATCHES=(
)
python_check_deps() {
- has_version "dev-python/CppHeaderParser[${PYTHON_USEDEP}]" &&
- has_version "dev-python/ply[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/CppHeaderParser[${PYTHON_USEDEP}]" \
+ "dev-python/ply[${PYTHON_USEDEP}]"
}
src_prepare() {