summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/sccache/sccache-9999.ebuild')
-rw-r--r--dev-util/sccache/sccache-9999.ebuild69
1 files changed, 47 insertions, 22 deletions
diff --git a/dev-util/sccache/sccache-9999.ebuild b/dev-util/sccache/sccache-9999.ebuild
index d4ca5fcba08e..ebb46ec79d8d 100644
--- a/dev-util/sccache/sccache-9999.ebuild
+++ b/dev-util/sccache/sccache-9999.ebuild
@@ -1,38 +1,52 @@
-# Copyright 2017-2021 Gentoo Authors
+# Copyright 2017-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+# Autogenerated by pycargoebuild 0.7
+
+EAPI=8
CRATES="
"
-inherit cargo optfeature
+inherit cargo optfeature systemd
DESCRIPTION="ccache/distcc like tool with support for rust and cloud storage"
HOMEPAGE="https://github.com/mozilla/sccache/"
-if [ ${PV} == "9999" ] ; then
+if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/mozilla/sccache.git"
else
- SRC_URI="https://github.com/mozilla/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris ${CRATES})"
+ SRC_URI="
+ https://github.com/mozilla/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}
+ "
KEYWORDS="~amd64 ~ppc64"
fi
-LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 Boost-1.0 ISC MIT Unlicense ZLIB"
+LICENSE="Apache-2.0"
+# Dependent crate licenses
+LICENSE+="
+ Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB
+"
SLOT="0"
-IUSE="azure dist-client dist-server gcs memcached redis s3"
-
-BDEPEND="virtual/pkgconfig"
-
+IUSE="azure dist-client dist-server gcs memcached redis s3 simple-s3"
+# See https://github.com/mozilla/sccache/issues/1820, hopefully temporary.
+RESTRICT="test"
+REQUIRED_USE="s3? ( simple-s3 )"
+
+BDEPEND="
+ virtual/pkgconfig
+ >=virtual/rust-1.65
+"
DEPEND="
app-arch/zstd
- dist-server? ( dev-libs/openssl:0= )
- gcs? ( dev-libs/openssl:0= )
+ sys-libs/zlib:=
+ dist-server? ( dev-libs/openssl:= )
+ gcs? ( dev-libs/openssl:= )
"
-
-RDEPEND="${DEPEND}
+RDEPEND="
+ ${DEPEND}
dist-server? ( sys-apps/bubblewrap )
"
@@ -48,7 +62,12 @@ src_unpack() {
}
src_configure() {
+ # Should be able to drop this once we have a 'gentoo' profile
+ sed -i 's/strip = true/strip = false/' Cargo.toml || die
+
+ export ZSTD_SYS_USE_PKG_CONFIG=1
myfeatures=(
+ native-zlib
$(usev azure)
$(usev dist-client)
$(usev dist-server)
@@ -56,10 +75,20 @@ src_configure() {
$(usev memcached)
$(usev redis)
$(usev s3)
+ $(usev simple-s3)
)
+
cargo_src_configure --no-default-features
}
+src_test() {
+ if [[ "${PV}" == *9999* ]]; then
+ ewarn "tests are always broken for ${PV} (require network), skipping"
+ else
+ cargo_src_test
+ fi
+}
+
src_install() {
cargo_src_install
@@ -74,14 +103,10 @@ src_install() {
newinitd "${FILESDIR}"/scheduler.initd sccache-scheduler
newconfd "${FILESDIR}"/scheduler.confd sccache-scheduler
- fi
-}
-src_test() {
- if [[ "${PV}" == *9999* ]]; then
- ewarn "tests are always broken for ${PV} (require network), skipping"
- else
- cargo_src_test
+ systemd_dounit "${FILESDIR}"/sccache-server.service
+ systemd_dounit "${FILESDIR}"/sccache-scheduler.service
+
fi
}