summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/statifier')
-rw-r--r--dev-util/statifier/Manifest1
-rw-r--r--dev-util/statifier/metadata.xml12
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/statifier/Manifest b/dev-util/statifier/Manifest
new file mode 100644
index 000000000000..b27b88532ec6
--- /dev/null
+++ b/dev-util/statifier/Manifest
@@ -0,0 +1 @@
+DIST statifier-1.7.4.tar.gz 73245 BLAKE2B 897b78b31aa4f148b6a6a986251ba9d4f40ebad3209f71896ffffb71e06ab25d337a4a79adc0217592051f917bc71428d3032f6216ec053f62c4632edef474d5 SHA512 22d4873130bafe06144c8f6ce7089aa25e3eb047bbee5709344fee1e8d85b24aac689c88d34537fe4a690e231d768e56a2fa13672b9eccf27d945b3f8bcda756
diff --git a/dev-util/statifier/metadata.xml b/dev-util/statifier/metadata.xml
new file mode 100644
index 000000000000..54d5423c4060
--- /dev/null
+++ b/dev-util/statifier/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
new file mode 100644
index 000000000000..2e2867cd1b96
--- /dev/null
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
+HOMEPAGE="http://statifier.sourceforge.net"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="app-shells/bash
+ sys-apps/coreutils
+ virtual/awk"
+
+src_prepare() {
+ # Respect users CFLAGS and LDFLAGS
+ sed -i -e 's/-Wall -O2/$(CFLAGS) $(LDFLAGS)/g' src/Makefile || die
+
+ # Apply user patches
+ eapply_user
+}
+
+src_configure() {
+ # Fix permissions, as configure is not marked executable
+ chmod +x configure || die
+ econf
+}
+
+src_compile() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1
+}
+
+src_install() {
+ # Package complains with MAKEOPTS > -j1
+ emake -j1 DESTDIR="${D}" install
+
+ # Install docs
+ einstalldocs
+}