summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/bfg/bfg-1.13.0.ebuild')
-rw-r--r--dev-vcs/bfg/bfg-1.13.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-vcs/bfg/bfg-1.13.0.ebuild b/dev-vcs/bfg/bfg-1.13.0.ebuild
new file mode 100644
index 000000000000..d321b3273889
--- /dev/null
+++ b/dev-vcs/bfg/bfg-1.13.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2
+
+DESCRIPTION="a faster alternative to git-filter-branch for removing bad data from git repos"
+HOMEPAGE="https://rtyley.github.io/bfg-repo-cleaner/"
+SRC_URI="https://repo1.maven.org/maven2/com/madgag/${PN}/${PV}/${P}.jar"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.7"
+
+S=${WORKDIR}
+
+src_prepare() {
+ default
+ java-pkg-2_src_prepare
+}
+
+src_unpack() { :; }
+src_compile() { :; }
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}"/${P}.jar
+ java-pkg_dolauncher ${PN}
+}