summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/bfg')
-rw-r--r--dev-vcs/bfg/bfg-1.13.0.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/dev-vcs/bfg/bfg-1.13.0.ebuild b/dev-vcs/bfg/bfg-1.13.0.ebuild
index 93e964d47199..90b1cc8cd116 100644
--- a/dev-vcs/bfg/bfg-1.13.0.ebuild
+++ b/dev-vcs/bfg/bfg-1.13.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit java-pkg-2
-DESCRIPTION="a faster alternative to git-filter-branch for removing bad data from git repos"
+DESCRIPTION="A faster alternative to git-filter-branch for removing bad data from git repos"
HOMEPAGE="https://rtyley.github.io/bfg-repo-cleaner/"
SRC_URI="https://repo1.maven.org/maven2/com/madgag/${PN}/${PV}/${P}.jar"
@@ -13,19 +13,11 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 ~x86"
-DEPEND="app-arch/unzip"
-RDEPEND=">=virtual/jre-1.7"
+RDEPEND=">=virtual/jre-1.8:*"
+BDEPEND="app-arch/unzip"
S=${WORKDIR}
-src_prepare() {
- default
- java-pkg-2_src_prepare
-}
-
-src_unpack() { :; }
-src_compile() { :; }
-
src_install() {
java-pkg_newjar "${DISTDIR}"/${P}.jar
java-pkg_dolauncher ${PN}