summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/git-2.7.4.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-vcs/git/git-2.7.4.ebuild b/dev-vcs/git/git-2.7.4.ebuild
index 06a2a18f46f1..a46fe25640b7 100644
--- a/dev-vcs/git/git-2.7.4.ebuild
+++ b/dev-vcs/git/git-2.7.4.ebuild
@@ -540,7 +540,9 @@ src_install() {
# we could remove sources in src_prepare, but install does not
# handle missing locale dir well
rm_loc() {
- rm -r "${ED}/usr/share/locale/${1}" || die
+ if [[ -e "${ED}/usr/share/locale/${1}" ]]; then
+ rm -r "${ED}/usr/share/locale/${1}" || die
+ fi
}
l10n_for_each_disabled_locale_do rm_loc
}