summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/gitg')
-rw-r--r--dev-vcs/gitg/Manifest1
-rw-r--r--dev-vcs/gitg/gitg-3.32.1.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-vcs/gitg/Manifest b/dev-vcs/gitg/Manifest
index 3f72ce9e834b..507c08043cae 100644
--- a/dev-vcs/gitg/Manifest
+++ b/dev-vcs/gitg/Manifest
@@ -1,2 +1,3 @@
DIST gitg-3.26.0.tar.xz 1551308 BLAKE2B 45a9fd3df8eb891c4e07eefb6cf8f9b517c78dccc63dd08498b4c847614e164472e0605a01c81515ea349366e56c21c99a4558e73b6548b18bb94f578c0fc9bd SHA512 782aa02e2f0f4d8c86ad726045502d545877d835f0449d2ec646d93a78bbfa50f84662d3a437c922eb168b2737c00ec088dc2c73487742f332e3910f041b519d
DIST gitg-3.30.1.tar.xz 10555888 BLAKE2B 02e8f957eee82bbf0702ca39b5b336929c131a93a94f5e28a2e4aa7c2c473c5d8bda072eba184cef37d6ad2fa7bfa21c007c86204a0a81b6d401487d752952fd SHA512 0d9241422dda6bf1840632fbcabf6b640554081ba995eba59ce90f893654e42c0ca8953e814533b90f362abb13b002e7a74b5f6841aee1f33c2834d2acab869f
+DIST gitg-3.32.1.tar.xz 10613836 BLAKE2B 43c2c37f5c06cb6155906d5988f0787334af7a9091e537fa7b0fc1a9de3138f261a3e3c578afc663c7b57a33f39c19318a53daf7896c465922138197c3bbb778 SHA512 243e630b3e5bb1919dc307e6b3fed1b1b0e3884d2a2507e4526b4af61e86f1cd7004a3dbb96001ffb0280cefe7cdb9b109c39996718913c7410224830c0145a4
diff --git a/dev-vcs/gitg/gitg-3.32.1.ebuild b/dev-vcs/gitg/gitg-3.32.1.ebuild
new file mode 100644
index 000000000000..94e17d845324
--- /dev/null
+++ b/dev-vcs/gitg/gitg-3.32.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+VALA_MIN_API_VERSION="0.32" # Needed when gtk+-3.20 is found
+
+inherit gnome.org gnome2-utils meson python-r1 vala xdg-utils
+
+DESCRIPTION="git repository viewer for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gitg"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="glade +python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# test if unbundling of libgd is possible
+# Currently it seems not to be (unstable API/ABI)
+RDEPEND="
+ app-crypt/libsecret[vala]
+ >=app-text/gtkspell-3.0.3:3[vala]
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/gobject-introspection-0.10.1:=
+ dev-libs/libdazzle[vala]
+ dev-libs/libgee:0.8[introspection]
+ dev-libs/libgit2:=[threads]
+
+ >=dev-libs/libgit2-glib-0.27[ssh]
+ <dev-libs/libgit2-glib-0.29
+
+ >=dev-libs/libpeas-1.5.0[gtk]
+ >=dev-libs/libxml2-2.9.0:2
+ >=gnome-base/gsettings-desktop-schemas-0.1.1
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-3.20.0:3
+ >=x11-libs/gtksourceview-3.10:3.0
+ x11-themes/adwaita-icon-theme
+ glade? ( >=dev-util/glade-3.2:3.10 )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-libs/libgit2-glib-0.24.4[vala]
+ >=sys-devel/gettext-0.19.7
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ vala_src_prepare
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use glade glade_catalog)
+ # we install the module manually anyway
+ -Dpython=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use python ; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule libgitg-ext/GitgExt.py
+ fi
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}