summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/gitinspector')
-rw-r--r--dev-vcs/gitinspector/Manifest1
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.4.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-vcs/gitinspector/Manifest b/dev-vcs/gitinspector/Manifest
index 44d4ed0eea3b..f86771360804 100644
--- a/dev-vcs/gitinspector/Manifest
+++ b/dev-vcs/gitinspector/Manifest
@@ -1,2 +1,3 @@
+DIST gitinspector-0.4.2.tar.gz 312781 SHA256 4c10d2a6a7964f0a38bd7fa8429f3d5095bf56d829c07a38256810cae0793f55 SHA512 144f2cf03f7cb426ccb9a28a6328bd54e6f13cf56d255829a78f31292be63d3f91dcd76525b1bdee514aff7ec20869acae9dc1f0683261ca9bbab29e660cc915 WHIRLPOOL 95fea80bf15f26d6147acca63a80786443a5d4bc6a35710825e73eed13e49212eab9535757f9b0958fec18ed5513a2905839e961631f77e0c9a8ccb816557505
DIST gitinspector_0.3.1.zip 235252 SHA256 0081f142e507ff49cb4f5ca1119eb11f66655af1bfb327aa4670c31245e608d0 SHA512 f7ba3b4ebededc8ff80e440de26c3e858c4e413dd02c516aa442c05ef27875e0eb78e6430018717890aa390ef5a1011a33da28e0748a07c59830df6ffeb35c63 WHIRLPOOL 95d80614a5f2c38c9c01e5958f778eb72935f81e3aa44bd831332047f633625587f75f598112c005b0709c7b209a732286c1da578c07c74c22066c65d31d2964
DIST gitinspector_0.3.2.zip 254971 SHA256 3778e60514f5067f8f2628da5cacbce12db99af6517fcf448afb2964bce963a7 SHA512 2a6a48f2b1b7f7add11be034addca727845aa50860286ea50a4fff0a84b14f840c2776dd679b8c2f11d528b93712c7384aa318ffb08bb01f69faf436b6bcaa5a WHIRLPOOL df6f808ea3bd1b04bcf99416d2f5abb3b6241c6212d22676058ed73e9406c39a517881c01c3f73f26e880b648de131422134a1112f7dfd81ebc30837eb0166b7
diff --git a/dev-vcs/gitinspector/gitinspector-0.4.2.ebuild b/dev-vcs/gitinspector/gitinspector-0.4.2.ebuild
new file mode 100644
index 000000000000..3110f61f80ef
--- /dev/null
+++ b/dev-vcs/gitinspector/gitinspector-0.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical analysis tool for git repositories"
+HOMEPAGE="https://github.com/ejwa/gitinspector"
+SRC_URI="https://github.com/ejwa/gitinspector/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-vcs/git"
+DEPEND="
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ [[ ${LC_ALL} == "C" ]] && export LC_ALL="en_US.utf8"
+ distutils-r1_python_prepare_all
+}