summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/atanks/atanks-6.4.ebuild')
-rw-r--r--games-action/atanks/atanks-6.4.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-action/atanks/atanks-6.4.ebuild b/games-action/atanks/atanks-6.4.ebuild
new file mode 100644
index 000000000000..0646c0307d51
--- /dev/null
+++ b/games-action/atanks/atanks-6.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="Worms and Scorched Earth-like game"
+HOMEPAGE="http://atanks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/atanks/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/allegro:0[X]"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ emake \
+ BINDIR="${GAMES_BINDIR}" \
+ INSTALLDIR="${GAMES_DATADIR}/${PN}"
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r button misc missile sound stock tank tankgun text title unicode.dat *.txt
+ doicon -s 48 ${PN}.png
+ make_desktop_entry atanks "Atomic Tanks"
+ dodoc Changelog README TODO
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}