summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/garden')
-rw-r--r--games-action/garden/files/garden-1.0.9-fnocommon.patch11
-rw-r--r--games-action/garden/garden-1.0.9-r2.ebuild48
2 files changed, 59 insertions, 0 deletions
diff --git a/games-action/garden/files/garden-1.0.9-fnocommon.patch b/games-action/garden/files/garden-1.0.9-fnocommon.patch
new file mode 100644
index 000000000000..59d011f5f402
--- /dev/null
+++ b/games-action/garden/files/garden-1.0.9-fnocommon.patch
@@ -0,0 +1,11 @@
+--- a/src/main.c 2020-09-18 22:43:49.545959883 -0000
++++ b/src/main.c 2020-09-18 22:43:40.465778941 -0000
+@@ -55,7 +55,7 @@ struct enemystruct enemy [NO_ENEMIES];
+ struct ebulletstruct ebullet [NO_EBULLETS];
+ struct pbulletstruct pbullet [NO_PBULLETS];
+ struct arenastruct arena;
+-struct eclassstruct eclass [NO_ENEMY_TYPES];
++extern struct eclassstruct eclass [NO_ENEMY_TYPES];
+ struct cloudstruct cloud [NO_CLOUDS];
+ struct bossstruct boss;
+
diff --git a/games-action/garden/garden-1.0.9-r2.ebuild b/games-action/garden/garden-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..5200fa04163f
--- /dev/null
+++ b/games-action/garden/garden-1.0.9-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic xdg-utils
+
+DESCRIPTION="Multiplatform vertical shoot-em-up with non-traditional elements"
+HOMEPAGE="http://garden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="<media-libs/allegro-5"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dash.patch"
+ "${FILESDIR}/${P}-resources.patch"
+ "${FILESDIR}/${P}-fnocommon.patch"
+)
+
+src_prepare() {
+ default
+
+ # build with gcc52
+ sed -i \
+ -e 's/inline/extern inline/' \
+ src/stuff.h || die
+ eautoreconf
+ append-cflags -std=gnu89 # build with gcc5 (bug #572672)
+}
+
+src_install() {
+ default
+ doicon -s scalable resources/garden.svg
+ make_desktop_entry garden "Garden of coloured lights"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}