summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/netris/netris-0.52.ebuild')
-rw-r--r--games-arcade/netris/netris-0.52.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/games-arcade/netris/netris-0.52.ebuild b/games-arcade/netris/netris-0.52.ebuild
deleted file mode 100644
index 5e0d8019bfcc..000000000000
--- a/games-arcade/netris/netris-0.52.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils games
-
-DEB_VER=7
-DESCRIPTION='Classic networked version of T*tris'
-HOMEPAGE='http://www.netris.org/'
-SRC_URI="ftp://ftp.netris.org/pub/netris/${P}.tar.gz
- mirror://debian/pool/main/n/netris/netris_${PV}-${DEB_VER}.diff.gz"
-
-LICENSE='GPL-2'
-SLOT='0'
-KEYWORDS='amd64 ~mips ppc ~sparc x86 ~x86-fbsd'
-IUSE=''
-
-DEPEND='sys-libs/ncurses'
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${WORKDIR}"/netris_${PV}-${DEB_VER}.diff
- # bug #185332
- sed -i \
- -e '/sys\/time/ i\
-#include <sys/types.h> \
-#include <time.h>
-' \
- -e '/netint2/ s/short/int16_t/' \
- -e '/netint4/ s/long/int32_t/' \
- netris.h \
- || die 'sed failed'
- sed -i \
- -e '/curses\.h/ a\
-#include <term.h>
-' \
- curses.c \
- || die 'sed failed'
- sed -i \
- -e 's/volatile //g' \
- -e '/Be more forgiving/d' \
- -e 's/static myRandSeed/static int myRandSeed/' \
- util.c \
- || die 'sed failed'
- sed -i \
- -e 's/\(long pauseTimeLeft\)/\1 = 0/' \
- game.c \
- || die 'sed failed'
- sed -i \
- -e '/^CC/d' \
- -e '/^COPT/d' \
- -e '/^CFLAGS/d' \
- -e 's/(LFLAGS)/(LDFLAGS) $(LFLAGS)/' \
- Configure \
- || die 'sed failed'
-}
-
-src_configure() {
- bash ./Configure -O || die 'Configure failed'
-}
-
-src_install() {
- dogamesbin netris sr
- dodoc FAQ README robot_desc
- prepgamesdirs
-}