summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/openmortal/files/openmortal-0.7-freetype_pkgconfig.patch')
-rw-r--r--games-arcade/openmortal/files/openmortal-0.7-freetype_pkgconfig.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/games-arcade/openmortal/files/openmortal-0.7-freetype_pkgconfig.patch b/games-arcade/openmortal/files/openmortal-0.7-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..fe683899f2e9
--- /dev/null
+++ b/games-arcade/openmortal/files/openmortal-0.7-freetype_pkgconfig.patch
@@ -0,0 +1,24 @@
+--- openmortal-0.7/configure.in
++++ openmortal-0.7/configure.in
+@@ -25,6 +25,7 @@
+ AC_C_CONST
+ AC_PROG_CXX
+
++PKG_PROG_PKG_CONFIG
+
+ dnl
+ dnl Switches
+@@ -122,11 +123,8 @@
+
+ dnl Check for Freetype 2 library
+
+-FT2_VERSION=2.1.0
+-AC_CHECK_FT2(
+- $FT2_VERSION,
+- :,
+- AC_MSG_ERROR([*** FreeType 2 version $FT2_VERSION not found!])
++PKG_CHECK_MODULES(FT2, freetype2,,
++ AC_MSG_ERROR([*** FreeType2 not found!])
+ )
+ CXXFLAGS="$CXXFLAGS $FT2_CFLAGS"
+ LIBS="$LIBS $FT2_LIBS"