summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supertux/Manifest1
-rw-r--r--games-arcade/supertux/files/supertux-0.1.3-desktop.patch21
-rw-r--r--games-arcade/supertux/files/supertux-0.1.3-gcc41.patch11
-rw-r--r--games-arcade/supertux/files/supertux-0.1.3-ndebug.patch14
-rw-r--r--games-arcade/supertux/supertux-0.1.3.ebuild43
5 files changed, 0 insertions, 90 deletions
diff --git a/games-arcade/supertux/Manifest b/games-arcade/supertux/Manifest
index a24f26b8b2b5..30519d339457 100644
--- a/games-arcade/supertux/Manifest
+++ b/games-arcade/supertux/Manifest
@@ -1,2 +1 @@
-DIST supertux-0.1.3.tar.bz2 6715265 SHA256 0092588351776626955339caaa62d12ce5954bb80c5f6952f60a122f53c2ad97 SHA512 75848583f9f9b9d0f36fec77812501875420fde8befe1ff9ac4ea7613f4d9464b2eb460c2ed89b4dc31e697fbb449a5431c72675e2820d13f5c42653dc07ad98 WHIRLPOOL bb8998845bee7f33a7aff94109d9767d000c89df6c670a1ccb85c4e9158a8ce6c4064f89587b9ea40d9ba1a854b9f5bba82ccc7dcac6dedcdb337cfaa1777898
DIST supertux-0.4.0.tar.bz2 79713147 SHA256 d18dde3c415e619b4bb035e694ffc384be16576250c9df16929d9ec38daff782 SHA512 66ca63c982b6076847662c187069eb965211439e5dfc628300f2a9bd0d2b4c0f7b53f6e7c2aed263c098cc9b77fedf132e73b1f3b3eacaf5535cae8300262fb5 WHIRLPOOL 12551b655f0459a37d3b91b1eff058ec383df34c9f3c29c1e8a63c070c12b32ec798b772053cd08b11d32b612bab1188b69678e71585279e94ad380052076f64
diff --git a/games-arcade/supertux/files/supertux-0.1.3-desktop.patch b/games-arcade/supertux/files/supertux-0.1.3-desktop.patch
deleted file mode 100644
index 2fd7742fc030..000000000000
--- a/games-arcade/supertux/files/supertux-0.1.3-desktop.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- supertux.desktop.orig
-+++ supertux.desktop
-@@ -1,7 +1,6 @@
- [Desktop Entry]
- Type=Application
- Version=1.0
--Encoding=UTF-8
- Name=SuperTux
- Name[en]=SuperTux
- Name[de]=SuperTux
-@@ -14,8 +13,8 @@
- Comment[en]=A Super Mario inspired penguin platform game
- Comment[de]=Ein von Super Mario inspiriertes Pinguin Jump&Run Spiel
- Comment[cs]=Plošinovka inspirovaná SuperMariem s tučňákem Tuxem v hlavní roli
--Icon=supertux.png
-+Icon=supertux
- Exec=supertux
- Terminal=false
- StartupNotify=false
--Categories=Application;Game;ArcadeGame
-+Categories=Game;ArcadeGame;
diff --git a/games-arcade/supertux/files/supertux-0.1.3-gcc41.patch b/games-arcade/supertux/files/supertux-0.1.3-gcc41.patch
deleted file mode 100644
index 449dc3b72a00..000000000000
--- a/games-arcade/supertux/files/supertux-0.1.3-gcc41.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- supertux-0.1.3.orig/src/menu.h
-+++ supertux-0.1.3/src/menu.h
-@@ -207,7 +207,7 @@
-
- bool isToggled(int id);
-
-- void Menu::get_controlfield_key_into_input(MenuItem *item);
-+ void get_controlfield_key_into_input(MenuItem *item);
-
- void draw ();
- void draw_item(int index, int menu_width, int menu_height);
diff --git a/games-arcade/supertux/files/supertux-0.1.3-ndebug.patch b/games-arcade/supertux/files/supertux-0.1.3-ndebug.patch
deleted file mode 100644
index 197a51802eaf..000000000000
--- a/games-arcade/supertux/files/supertux-0.1.3-ndebug.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- supertux-0.1.3.orig/src/tile.cpp
-+++ supertux-0.1.3/src/tile.cpp
-@@ -99,7 +99,11 @@ void TileManager::load_tileset(std::stri
- tile->anim_speed = 25;
-
- LispReader reader(lisp_cdr(element));
-+ #ifdef NDEBUG
-+ void(reader.read_int("id", &tile->id));
-+ #else
- assert(reader.read_int("id", &tile->id));
-+ #endif
- reader.read_bool("solid", &tile->solid);
- reader.read_bool("brick", &tile->brick);
- reader.read_bool("ice", &tile->ice);
diff --git a/games-arcade/supertux/supertux-0.1.3.ebuild b/games-arcade/supertux/supertux-0.1.3.ebuild
deleted file mode 100644
index 632c953c1182..000000000000
--- a/games-arcade/supertux/supertux-0.1.3.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils games
-
-DESCRIPTION="A game similar to Super Mario Bros"
-HOMEPAGE="http://super-tux.sourceforge.net"
-SRC_URI="https://supertux.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~mips ppc ~ppc64 sparc x86 ~x86-fbsd"
-IUSE="opengl"
-
-DEPEND="media-libs/libsdl[joystick]
- media-libs/sdl-image[png,jpeg]
- media-libs/sdl-mixer[mod,vorbis]
- x11-libs/libXt"
-RDEPEND=${DEPEND}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-ndebug.patch \
- "${FILESDIR}"/${P}-desktop.patch
-}
-
-src_configure() {
- egamesconf \
- --disable-debug \
- $(use_enable opengl)
-}
-
-src_install() {
- emake DESTDIR="${D}" \
- desktopdir=/usr/share/applications \
- icondir=/usr/share/pixmaps \
- install
- dodoc AUTHORS ChangeLog LEVELDESIGN README TODO
- prepgamesdirs
-}