summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/ceferino/Manifest1
-rw-r--r--games-arcade/ceferino/ceferino-0.97.8-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/games-arcade/ceferino/Manifest b/games-arcade/ceferino/Manifest
index 361afea91679..e43c2178863f 100644
--- a/games-arcade/ceferino/Manifest
+++ b/games-arcade/ceferino/Manifest
@@ -1 +1,2 @@
DIST ceferino-0.97.8.tar.gz 2380632 SHA256 6f0f2674a8a968950498570b89123e341dca50499d255e7bcdf3703a85aa3074 SHA512 459e5b5e19ff9cfc8bd82af856dea68d5f8694ff2b4a04e35c1b3fa1d065c8d8c60025b5e9ea1918eae4bf12a9ca354187513a3cb2813a55d39ef57deb2a7d05 WHIRLPOOL f989e81fc032ea6c65486d07ce80834052aa7ac31b3aceebe1580212817a3f59f6e0bb2b9fd1fa0fe1d14c11af164965675d164b836b7c032a0ddce21c39d3d4
+DIST ceferino_0.97.8+svn37.orig.tar.gz 2104956 SHA256 b52ccce6051e78d8c368d76335d027442162e6bac44709ef06627a8fa8cb2fc6 SHA512 83bccb39f0ecd9f41767c4d94cebb3266c77f11eb22d6cf517f6488af384bad88bdd538b5746e0a3c6e1a57481a4c946ec03afb97a000cd21664d3f179e1a9b6 WHIRLPOOL d8bbba49f1864aaf92f52d45a45f46cb0d1d112e7868f979da903149119496faeee179849df949e904ed9ac39b0259d7210d1e4a7a4a38bc3a5131d1230575dd
diff --git a/games-arcade/ceferino/ceferino-0.97.8-r1.ebuild b/games-arcade/ceferino/ceferino-0.97.8-r1.ebuild
new file mode 100644
index 000000000000..129298b97027
--- /dev/null
+++ b/games-arcade/ceferino/ceferino-0.97.8-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils games
+
+DESCRIPTION="Super-Pang clone (destroy bouncing balloons with your grapnel)"
+HOMEPAGE="http://www.loosersjuegos.com.ar/juegos/ceferino"
+SRC_URI="mirror://debian/pool/main/c/ceferino/${PN}_${PV}+svn37.orig.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=media-libs/libsdl-1.2[video]
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${P}+svn37
+
+src_prepare() {
+ sed -i \
+ -e '/^INCLUDES/s:\$(datadir)/locale:/usr/share/locale:' \
+ src/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_enable nls)
+}
+
+src_install() {
+ default
+ newicon data/ima/icono.png ${PN}.png
+ make_desktop_entry ceferino "Don Ceferino HazaƱa"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if ! has_version "media-libs/sdl-mixer[mod]" ; then
+ ewarn
+ ewarn "To hear music, you will have to rebuild media-libs/sdl-mixer"
+ ewarn "with the \"mod\" USE flag turned on."
+ ewarn
+ fi
+}