summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/atakks')
-rw-r--r--games-board/atakks/Manifest1
-rw-r--r--games-board/atakks/atakks-1.0.ebuild46
-rw-r--r--games-board/atakks/files/1.0-warnings.patch28
-rw-r--r--games-board/atakks/files/atakks-1.0-as-needed.patch16
-rw-r--r--games-board/atakks/metadata.xml5
5 files changed, 96 insertions, 0 deletions
diff --git a/games-board/atakks/Manifest b/games-board/atakks/Manifest
new file mode 100644
index 000000000000..ec4eae85feb9
--- /dev/null
+++ b/games-board/atakks/Manifest
@@ -0,0 +1 @@
+DIST atakks-1.0.tar.gz 62464 SHA256 40603b7029f0092bcd810b6930b595f29ee9b3a645d5a5037c52b7bbad499d81 SHA512 a4b31635ef74198c86002fc930922266f462926bffa5b1fd7fb8ba1186dbc1efd8ae8c84ac0a429737916d1350b5432967221a67505bfe73d47a6dadd7600e39 WHIRLPOOL d525ed8363738041d43f5776a27ea55489ab4a15bfc3beea1a2ee4240622cd10b234942681ae7cf03b4cd97a95eb685b11cf0baf15449b5eedb514d277648220
diff --git a/games-board/atakks/atakks-1.0.ebuild b/games-board/atakks/atakks-1.0.ebuild
new file mode 100644
index 000000000000..dfa22905526f
--- /dev/null
+++ b/games-board/atakks/atakks-1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+MY_P=${P/-/_}
+DESCRIPTION="A clone of Ataxx"
+HOMEPAGE="http://team.gcu-squad.org/~fab"
+# no version upstream
+#SRC_URI="http://team.gcu-squad.org/~fab/down/${PN}.tgz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl:0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # Modify game data paths
+ sed -i \
+ -e "s:SDL_LoadBMP(\":SDL_LoadBMP(\"${GAMES_DATADIR}/${PN}/:" \
+ main.c || die
+
+ epatch "${FILESDIR}"/${PV}-warnings.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ emake E_CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins *bmp
+ newicon icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Atakks /usr/share/pixmaps/${PN}.bmp
+ prepgamesdirs
+}
diff --git a/games-board/atakks/files/1.0-warnings.patch b/games-board/atakks/files/1.0-warnings.patch
new file mode 100644
index 000000000000..a27e014d9603
--- /dev/null
+++ b/games-board/atakks/files/1.0-warnings.patch
@@ -0,0 +1,28 @@
+--- main.c.orig 2004-06-02 01:26:00.000000000 -0700
++++ main.c 2004-06-02 01:27:30.000000000 -0700
+@@ -13,6 +13,7 @@
+ #include<SDL/SDL.h>
+ #include<unistd.h>
+ #include<stdlib.h> /* atexit */
++#include<string.h>
+ #include "defs.h"
+ void virus(Uint8 posX, Uint8 posY)
+ {
+@@ -206,7 +207,7 @@
+ int main(int argc, char **argv)
+ {
+ struct move hoho;
+- Uint8 caseX, caseY,selx, sely, checked = 0, canmove = 1;
++ Uint8 caseX, caseY,selx = 0, sely = 0, checked = 0, canmove = 1;
+ SDL_Surface *ico;
+ int pions1=0, pions2=0;
+ if (SDL_Init(SDL_INIT_VIDEO) == -1) {
+@@ -238,7 +239,7 @@
+ argv[0]);
+ #else
+ printf
+- ("\nSyntax: %s OPTIONS\n\n options:\n-h\t\tPrint help\n-t n1 n2\tSet width=n1 and height=n2\n\-ai\t\tActivate 1 player mode, [i] key during game.\n\n",
++ ("\nSyntax: %s OPTIONS\n\n options:\n-h\t\tPrint help\n-t n1 n2\tSet width=n1 and height=n2\n-ai\t\tActivate 1 player mode, [i] key during game.\n\n",
+ argv[0]);
+
+ #endif /* */
diff --git a/games-board/atakks/files/atakks-1.0-as-needed.patch b/games-board/atakks/files/atakks-1.0-as-needed.patch
new file mode 100644
index 000000000000..b02e32002fa9
--- /dev/null
+++ b/games-board/atakks/files/atakks-1.0-as-needed.patch
@@ -0,0 +1,16 @@
+--- Makefile.old 2009-02-03 10:02:08.000000000 +0100
++++ Makefile 2009-02-03 10:04:12.000000000 +0100
+@@ -1,10 +1,10 @@
+-LDFLAGS= -lSDL -lpthread -s
+-CFLAGS= -Wall -ansi # -DDEBUG
++LDLIBS = -lSDL
++CFLAGS= $(E_CFLAGS) -DUS -Wall -ansi # -DDEBUG
+ all: atakks
+ clean:
+ rm atakks *.o
+ atakks: main.o
+- $(CC) $(LDFLAGS) $< -o $@
++ $(CC) $(LDFLAGS) $< -o $@ $(LDLIBS)
+ pkg:
+ mkdir atakks-src
+ cp *.bmp main.c Makefile README atakks-src
diff --git a/games-board/atakks/metadata.xml b/games-board/atakks/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/atakks/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>