summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/cgoban/cgoban-1.9.14-r2.ebuild')
-rw-r--r--games-board/cgoban/cgoban-1.9.14-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/cgoban/cgoban-1.9.14-r2.ebuild b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
new file mode 100644
index 000000000000..92cf71adde65
--- /dev/null
+++ b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="A Go-frontend"
+HOMEPAGE="http://cgoban1.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/imagemagick-tools
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
+src_prepare() {
+ # ${P}-cflags.patch patches configure.ac, not .in:
+ mv configure.{in,ac} || die
+
+ default
+
+ cp cgoban_icon.png ${PN}.png || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon ${PN}.png
+ make_desktop_entry cgoban Cgoban
+}