summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/cgoban2/cgoban2-2.6.12.ebuild')
-rw-r--r--games-board/cgoban2/cgoban2-2.6.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/games-board/cgoban2/cgoban2-2.6.12.ebuild b/games-board/cgoban2/cgoban2-2.6.12.ebuild
new file mode 100644
index 000000000000..55aa2bc51abc
--- /dev/null
+++ b/games-board/cgoban2/cgoban2-2.6.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit games
+
+DESCRIPTION="A Java client for the Kiseido Go Server, and a SGF editor"
+HOMEPAGE="http://www.gokgs.com/"
+SRC_URI="mirror://gentoo/cgoban-unix-${PV}.tar.bz2"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}/cgoban
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ sed -e "s:INSTALL_DIR:${GAMES_DATADIR}/${PN}:" \
+ "${FILESDIR}/${PN}" > "${D}${GAMES_BINDIR}/${PN}" || die
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins cgoban.jar
+ prepgamesdirs
+}