summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/gnome-chess')
-rw-r--r--games-board/gnome-chess/Manifest1
-rw-r--r--games-board/gnome-chess/gnome-chess-3.22.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-board/gnome-chess/Manifest b/games-board/gnome-chess/Manifest
index cce48c155190..61d43d6825dd 100644
--- a/games-board/gnome-chess/Manifest
+++ b/games-board/gnome-chess/Manifest
@@ -1,3 +1,4 @@
DIST gnome-chess-3.18.0.tar.xz 2779340 SHA256 c841198935d807618c3cecbf10ed24643390d504e17961717bac455f4e1b37ad SHA512 307ff5800792e231977288dedc7a04ccfbf74fc47de6263bacd19875a8092bef196eb97597fba975ff1f2a7fe9fcd802a3477a6099cf04e3ebcf4c7c94d0a094 WHIRLPOOL 0ad6868f7b27da1cbe0dbec8ee5facd0dc1189defbfbe3f2411dc23dedde3d3a09ef5eb8a59bd223ca973b1d141a28fa60323262a77f72c945089602fa5c0a40
DIST gnome-chess-3.20.1.tar.xz 2789828 SHA256 4715349339491bd7a1072d5d362b5df76efa2067f4363c4b37d9579201d8c66d SHA512 c9238a7076ace27ed00ab47ade7383b24d6115a8cc5a174b1367dce90f7a19435ca135cf80ad45330d1dc0079846d43b9970bfd4382d41bdd5ada41d91193ac6 WHIRLPOOL acffb6bcdcff8763e1c884b902dd26302f9ae4086c7f15d4767076014cc18972807a4b71c3dec1f1fa73d82ae952982db39f0be58d0dbb5d47b9781a42ad4213
DIST gnome-chess-3.22.0.tar.xz 2804884 SHA256 838040c120af08aaa8ef1a6a284e2de296b998b37e49adb9436a12b6a428154a SHA512 3b95631ea186fc0d02cdd6a7b3312c6efe2bb6d626e26f3bb7c54dfa33ee513b570ef2aa663b7f32e153231110b8556adb0ef21fba021b22577a9cafb1d4d246 WHIRLPOOL 6cded5a71f57e48fbee270e07b5c9f54663e0cb98aeecda03be1b28f7e59ff08c1fd561b3bf29315a6306587b4ca2eef19e36f2fba373c04516de3117bf69e06
+DIST gnome-chess-3.22.2.tar.xz 2774176 SHA256 dffdf7f5c5f4ea6bba7ff88b457a75ee5e4c5d9d522d27e1ea4a3d4bb3927792 SHA512 ae939c5a79b4f0ae24a8a5b4a3efa0620aaf913ef46d944abad7f638477b0d711e6ca6b7c1e593a67100ad1ae4b423c7d87c51808911cc38e6022a3fbeafb47e WHIRLPOOL 92fa30ec9ef3eba4dc3326535992214979178ef654626a4a9a4da8d9f881823c3fa1f737fe5e5676964f83c4c372d873701e36e2467d248d5730596cf91e668c
diff --git a/games-board/gnome-chess/gnome-chess-3.22.2.ebuild b/games-board/gnome-chess/gnome-chess-3.22.2.ebuild
new file mode 100644
index 000000000000..a087aa94a659
--- /dev/null
+++ b/games-board/gnome-chess/gnome-chess-3.22.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 vala readme.gentoo-r1
+
+DESCRIPTION="Play the classic two-player boardgame of chess"
+HOMEPAGE="https://wiki.gnome.org/Apps/Chess"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32:2
+ >=x11-libs/gtk+-3.19:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="For being able to play against computer you will
+ need to install a chess engine like, for example, games-board/gnuchess"
+
+src_prepare() {
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}