summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/iagno')
-rw-r--r--games-board/iagno/Manifest1
-rw-r--r--games-board/iagno/iagno-3.30.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/games-board/iagno/Manifest b/games-board/iagno/Manifest
index c2d5611e5405..630df006e805 100644
--- a/games-board/iagno/Manifest
+++ b/games-board/iagno/Manifest
@@ -1 +1,2 @@
DIST iagno-3.22.0.tar.xz 1815048 BLAKE2B 13d4cfa4e17c139cdf7bc5dd8b2962c35dc6cf245095d3657bb6dcab12eb9f028eec9410781ff0212a2c627121db3c1ca18c404657d1e524122d189a716b3ea2 SHA512 55309dad4b73e70ba007073222eb5cc719a7fc4e1925637d1f124f7ca6092a4c125cba48a9d80e46b97b16736d2266bbd86e8248c1c6e7898669ce703deef53e
+DIST iagno-3.30.0.tar.xz 750432 BLAKE2B 073353cb1dd732b07949536410d2746fc15462bb1ab9f0174d0a3e22a7b221ba8a13a57eb197192384f83e9d1e4c9373fef88e42e8aa1a454c30748294719ec9 SHA512 8acbcb6c03f46cd59555cd759d4291db671de76ca365416d21b6a0a7b3796fc03aeb4a4d2ef1fb69c17f8941262bb9e8403b19fd526e22e9ed2dc2e854834ca1
diff --git a/games-board/iagno/iagno-3.30.0.ebuild b/games-board/iagno/iagno-3.30.0.ebuild
new file mode 100644
index 000000000000..1a42da387eae
--- /dev/null
+++ b/games-board/iagno/iagno-3.30.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Dominate the board in a classic version of Reversi"
+HOMEPAGE="https://wiki.gnome.org/Apps/Iagno"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2
+ >=gnome-base/librsvg-2.32.0:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/gtk+-3.15:3
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.14
+"
+# libxml2:2 needed for glib-compile-resources xml-stripblanks attributes
+DEPEND="${COMMON_DEPEND}
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure VALAC="$(type -P true)"
+}