summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/maitretarot')
-rw-r--r--games-board/maitretarot/files/maitretarot-0.1.98-format.patch4
-rw-r--r--games-board/maitretarot/maitretarot-0.1.98-r1.ebuild27
2 files changed, 29 insertions, 2 deletions
diff --git a/games-board/maitretarot/files/maitretarot-0.1.98-format.patch b/games-board/maitretarot/files/maitretarot-0.1.98-format.patch
index b3ff1fe1db1f..d7b5ca55b093 100644
--- a/games-board/maitretarot/files/maitretarot-0.1.98-format.patch
+++ b/games-board/maitretarot/files/maitretarot-0.1.98-format.patch
@@ -1,5 +1,5 @@
---- src/game.c.old 2015-12-16 21:59:49.400430743 +0100
-+++ src/game.c 2015-12-16 21:59:11.085058332 +0100
+--- a/src/game.c 2015-12-16 21:59:49.400430743 +0100
++++ b/src/game.c 2015-12-16 21:59:11.085058332 +0100
@@ -642,7 +642,7 @@
(game, prev_winner, c, ((i + prev_winner) % 4),
game->players[((i + prev_winner) % 4)]->turn, &err))
diff --git a/games-board/maitretarot/maitretarot-0.1.98-r1.ebuild b/games-board/maitretarot/maitretarot-0.1.98-r1.ebuild
new file mode 100644
index 000000000000..8d4c97637c66
--- /dev/null
+++ b/games-board/maitretarot/maitretarot-0.1.98-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="server for the french tarot game maitretarot"
+HOMEPAGE="http://www.nongnu.org/maitretarot/"
+SRC_URI="https://savannah.nongnu.org/download/maitretarot/${PN}.pkg/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ dev-libs/libxml2
+ dev-games/libmaitretarot"
+RDEPEND=${DEPEND}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
+
+src_configure() {
+ econf --with-default-config-file="/etc/maitretarotrc.xml"
+}